summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Cloud/Mail.nix')
-rw-r--r--Omni/Cloud/Mail.nix42
1 files changed, 21 insertions, 21 deletions
diff --git a/Omni/Cloud/Mail.nix b/Omni/Cloud/Mail.nix
index bc14d93..61ccf30 100644
--- a/Omni/Cloud/Mail.nix
+++ b/Omni/Cloud/Mail.nix
@@ -10,11 +10,11 @@ Known issues:
mailserver = {
enable = true;
monitoring = {
- enable = false;
- alertAddress = "bsima@me.com";
+ enable = true;
+ alertAddress = "bsima@icloud.com";
};
- fqdn = "simatime.com";
- domains = ["simatime.com" "bsima.me"];
+ fqdn = "bensima.com";
+ domains = ["bensima.com" "simatime.com" "bsima.me"];
certificateScheme = "acme-nginx"; # let's encrypt, using named scheme instead of number
enableImap = true;
enablePop3 = true;
@@ -26,33 +26,33 @@ Known issues:
# Define proper virtual aliases instead of placeholder
extraVirtualAliases = {
- "blocked@simatime.com" = "ben@simatime.com";
+ "blocked@bensima.com" = "ben@bensima.com";
+
+ # forward old addresses to new domain
+ "ben@bsima.me" = "ben@bensima.com";
+ "ben@simatime.com" = "ben@bensima.com";
};
loginAccounts = {
- "ben@simatime.com" = {
+ "ben@bensima.com" = {
hashedPasswordFile = "/home/ben/hashed-mail-password";
aliases = [
- # my default email
+ # my old emails
+ "ben@simatime.com"
"ben@bsima.me"
- # admin stuff
- "postmaster@simatime.com"
- "abuse@simatime.com"
+ # admin stuff, necessary i think?
+ "postmaster@bensima.com"
+ "abuse@bensima.com"
];
- catchAll = ["simatime.com" "bsima.me"];
+ catchAll = ["bensima.com" "simatime.com" "bsima.me"];
quota = "10G";
};
- "dev@simatime.com" = {
+ "dev@bensima.com" = {
hashedPasswordFile = "/home/ben/hashed-mail-password";
- aliases = ["dev@bsima.me"];
+ aliases = ["dev@simatime.com" "dev@bsima.me"];
quota = "10G";
};
- "nick@simatime.com" = {
- hashedPassword = "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
- aliases = ["nicolai@simatime.com"];
- quota = "1G";
- };
- "monica@simatime.com" = {
+ "monica@bensima.com" = {
hashedPasswordFile = "/home/ben/hashed-mail-password";
quota = "1G";
};
@@ -70,7 +70,7 @@ Known issues:
pattern = "/^From:.*perfora\\.net/";
action = "REJECT Domain perfora.net is blocked";
}
-
+
# Block novastells.com.es domain
{
pattern = "/^Received:.*novastells\\.com\\.es/";
@@ -88,7 +88,7 @@ Known issues:
pattern = "/^Sender:.*novastells\\.com\\.es/";
action = "REJECT Domain novastells.com.es is blocked";
}
-
+
# Block optaltechtld.com domain
{
pattern = "/^Received:.*optaltechtld\\.com/";