summaryrefslogtreecommitdiff
path: root/Omni/Syncthing.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-03-25 11:41:20 -0400
committerBen Sima <ben@bsima.me>2025-04-15 15:22:43 -0400
commita20827fc0a7eb9a5bc9ae559b426b8c3f357ce3c (patch)
tree3b8a227751c0395a81bda50fcb1932dde53f4cb5 /Omni/Syncthing.nix
parent147dc38ec5963f594474d8d775312049d1f16902 (diff)
Enable syncthing on Beryllium too
This moves syncthing from the cloud only, and onto Beryllium as well. Also it gets rid of the nginx config because I don't really need access to it remotely like that.
Diffstat (limited to 'Omni/Syncthing.nix')
-rw-r--r--Omni/Syncthing.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/Omni/Syncthing.nix b/Omni/Syncthing.nix
new file mode 100644
index 0000000..fab013b
--- /dev/null
+++ b/Omni/Syncthing.nix
@@ -0,0 +1,19 @@
+{...}: let
+ ports = import ./Cloud/Ports.nix;
+in {
+ services.syncthing = {
+ enable = true;
+ guiAddress = "0.0.0.0:${toString ports.syncthing-gui}";
+ openDefaultPorts = true;
+ systemService = true;
+ configDir = "/var/lib/syncthing/.config/syncthing";
+
+ # Default settings for new users
+ settings = {
+ options = {
+ relaysEnabled = true;
+ urAccepted = -1; # Usage reporting: -1 = not decided, 0 = no, 1 = yes
+ };
+ };
+ };
+}