summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-03-04 09:50:47 -0500
committerBen Sima <ben@bsima.me>2025-03-18 08:54:17 -0400
commita41a3da7ce8d548f837c70d924e496eabec37496 (patch)
treeb1bd74377d538e76d357a1b8d263a1289204ae4a /Omni/Cloud/Web.nix
parente96bb4f778817c18b7a4488cd46fffd1b4e9544f (diff)
Add Monica configuration for Omni/Cloud
Configure Monica on Omni/Cloud. I had to setup PHP FastCGI so that nginx handles the PHP requests properly, and setup an email address for the service.
Diffstat (limited to 'Omni/Cloud/Web.nix')
-rw-r--r--Omni/Cloud/Web.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/Omni/Cloud/Web.nix b/Omni/Cloud/Web.nix
index 1225247..79886c3 100644
--- a/Omni/Cloud/Web.nix
+++ b/Omni/Cloud/Web.nix
@@ -103,6 +103,14 @@ in {
user = "nginx";
group = "nginx";
+ # Add PHP configuration for Monica
+ appendHttpConfig = ''
+ # PHP FastCGI configuration for Monica
+ upstream php-handler {
+ server unix:/run/phpfpm/monica.sock;
+ }
+ '';
+
virtualHosts = {
${rootDomain} = {
serverName = rootDomain;
@@ -149,6 +157,9 @@ in {
useACMEHost = rootDomain;
};
+ # Monica virtual host configuration is handled by the Monica service
+ # Don't add a manual entry here to avoid conflicts
+
"hoogle.${rootDomain}" = {
locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.hoogle}";
forceSSL = true;
@@ -288,6 +299,7 @@ in {
"sd"
"gerrit"
"git"
+ "monica"
# xmpp stuff
"upload"
"conference"