summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Syncthing.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-03-25 11:41:20 -0400
committerBen Sima <ben@bsima.me>2025-04-15 15:22:43 -0400
commita20827fc0a7eb9a5bc9ae559b426b8c3f357ce3c (patch)
tree3b8a227751c0395a81bda50fcb1932dde53f4cb5 /Omni/Cloud/Syncthing.nix
parent147dc38ec5963f594474d8d775312049d1f16902 (diff)
Enable syncthing on Beryllium too
This moves syncthing from the cloud only, and onto Beryllium as well. Also it gets rid of the nginx config because I don't really need access to it remotely like that.
Diffstat (limited to 'Omni/Cloud/Syncthing.nix')
-rw-r--r--Omni/Cloud/Syncthing.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/Omni/Cloud/Syncthing.nix b/Omni/Cloud/Syncthing.nix
deleted file mode 100644
index 7c13e6c..0000000
--- a/Omni/Cloud/Syncthing.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{config, ...}: let
- ports = import ./Ports.nix;
- rootDomain = config.networking.domain;
-in {
- services.syncthing = {
- enable = true;
- guiAddress = "0.0.0.0:${toString ports.syncthing-gui}";
- openDefaultPorts = true;
- systemService = true;
- configDir = "/var/lib/syncthing/.config/syncthing";
-
- # Default settings for new users
- settings = {
- options = {
- relaysEnabled = true;
- urAccepted = -1; # Usage reporting: -1 = not decided, 0 = no, 1 = yes
- };
- };
- };
-
- # Configure nginx as a reverse proxy for the Syncthing GUI
- services.nginx.virtualHosts."syncthing.${rootDomain}" = {
- forceSSL = true;
- enableACME = true;
- locations."/" = {
- proxyPass = "http://localhost:${toString ports.syncthing-gui}/";
- proxyWebsockets = true;
- extraConfig = ''
- proxy_set_header Host $host;
- proxy_set_header X-Real-IP $remote_addr;
- proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
- proxy_set_header X-Forwarded-Proto $scheme;
- proxy_read_timeout 600s;
- proxy_send_timeout 600s;
- '';
- };
- };
-}