summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/interegular.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/interegular.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/interegular.nix')
-rw-r--r--Omni/Bild/Deps/interegular.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/Omni/Bild/Deps/interegular.nix b/Omni/Bild/Deps/interegular.nix
index 24065d8..b46f4c8 100644
--- a/Omni/Bild/Deps/interegular.nix
+++ b/Omni/Bild/Deps/interegular.nix
@@ -1,5 +1,8 @@
-{ lib, sources, buildPythonPackage }:
-
+{
+ lib,
+ sources,
+ buildPythonPackage,
+}:
buildPythonPackage rec {
pname = "interegular";
version = sources.interegular.rev;
@@ -7,15 +10,15 @@ buildPythonPackage rec {
src = sources.interegular;
- propagatedBuildInputs = [ ];
+ propagatedBuildInputs = [];
doCheck = false; # no tests currently
- pythonImportsCheck = [ "interegular" ];
+ pythonImportsCheck = ["interegular"];
meta = with lib; {
description = "Allows to check regexes for overlaps.";
homepage = "https://github.com/MegaIng/interegular";
license = licenses.mit;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
};
}