summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/accelerate.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/accelerate.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/accelerate.nix')
-rw-r--r--Omni/Bild/Deps/accelerate.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/Omni/Bild/Deps/accelerate.nix b/Omni/Bild/Deps/accelerate.nix
index be1d2fd..55a8609 100644
--- a/Omni/Bild/Deps/accelerate.nix
+++ b/Omni/Bild/Deps/accelerate.nix
@@ -1,10 +1,16 @@
-{ fetchFromGitHub, buildPythonPackage, numpy, packaging, psutil, pyyaml, torch
+{
+ fetchFromGitHub,
+ buildPythonPackage,
+ numpy,
+ packaging,
+ psutil,
+ pyyaml,
+ torch,
}:
-
buildPythonPackage rec {
name = "accelerate";
version = "0.15.0";
- propagatedBuildInputs = [ numpy packaging psutil pyyaml torch ];
+ propagatedBuildInputs = [numpy packaging psutil pyyaml torch];
doCheck = false;
src = fetchFromGitHub {
owner = "huggingface";
@@ -13,4 +19,3 @@ buildPythonPackage rec {
sha256 = "sha256-agfbOaa+Nm10HZkd2Y7zR3R37n+vLNsxCyxZax6O3Lo=";
};
}
-