summaryrefslogtreecommitdiff
path: root/Biz/Que/Site.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Biz/Que/Site.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Biz/Que/Site.nix')
-rw-r--r--Biz/Que/Site.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/Biz/Que/Site.nix b/Biz/Que/Site.nix
index da51032..0c7da0c 100644
--- a/Biz/Que/Site.nix
+++ b/Biz/Que/Site.nix
@@ -1,6 +1,10 @@
-{ options, lib, config, pkgs, ... }:
-
-let
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}: let
cfg = config.services.que-website;
static = pkgs.stdenv.mkDerivation {
src = ./.;
@@ -31,8 +35,8 @@ in {
};
config = lib.mkIf cfg.enable {
systemd.services.que-website = {
- path = [ cfg.package pkgs.pandoc ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package pkgs.pandoc];
+ wantedBy = ["multi-user.target"];
script = ''
${cfg.package}/bin/que-website ${static} ${cfg.namespace}
'';