{
  buildPythonPackage,
  fetchFromGitHub,
  lib,
  setuptools,
  pytestCheckHook,
  python-multipart,
  starlette,
  typeguard,
  pygments,
  pytest,
  pytest-cov,
  httpx,
  hatchling,
  hatch-vcs,
}:
buildPythonPackage rec {
  pname = "ludic";
  version = "0.5.2";
  pyproject = true;

  src = fetchFromGitHub {
    owner = "getludic";
    repo = pname;
    rev = "refs/tags/${version}";
    hash = "sha256-Zcob2ljyeiCqnCobkDP4ihRTxvs5OtQ4y5+Itsgs/0o=";
  };

  nativeBuildInputs = [setuptools hatchling hatch-vcs];

  propagatedBuildInputs = [python-multipart starlette typeguard pygments];

  disabledTestPaths = ["tests/contrib/test_django.py"];

  nativeCheckInputs = [pytestCheckHook];

  checkInputs = [pytest pytest-cov httpx];

  pythonImportsCheck = ["ludic"];

  meta = with lib; {
    homepage = "https://github.com/getludic/ludic";
    description = "Web Development in Pure Python with Type-Guided Components.";
    changelog = "https://github.com/getludic/ludic/releases/tag/${version}";
    license = licenses.mit;
    maintainers = with maintainers; [bsima];
  };
}