{ nixpkgs ? import ./Bild.nix {} }:
with nixpkgs;
# Dev machine for work and building stuff.

bild.os {
  imports = [
    ./OsBase.nix
    ./Packages.nix
    ./Users.nix
    ./Dev/Configuration.nix
    ./Dev/Hardware.nix
    ./Dev/Hoogle.nix
    ./Dev/Networking.nix
    ./Dev/Dns.nix
    #./Dev/Wireguard.nix # this changed in the upgrade and I can't find docs
    ./Dragons.nix
    # ./Dev/Guix.nix # I need to package a bunch of guile libs first
  ];
  networking.hostName = "lithium";
  networking.domain = "dev.simatime.com";
  services.dragons = {
    enable = true;
    port = 8095;
    package = bild.run ./Dragons.hs;
    keep = "/var/dragons/keep";
    depo = "/var/dragons/depo";
  };
}