{ bild }:

# Dev machine for work and building stuff.

bild.os {
  imports = [
    ./OsBase.nix
    ./Packages.nix
    ./Users.nix
    ./Dev/Configuration.nix
    ./Dev/Hardware.nix
    ./Dev/Hoogle.nix
    ./Devalloc.nix
  ];
  networking.hostName = "lithium";
  networking.domain = "dev.simatime.com";
  services.devalloc = {
    enable = true;
    port = 8095;
    package = bild.ghc ./Devalloc.hs;
  };
}