{ pkgs, lib, ... }:

{
  services = {
    gitolite = {
      enable = true;
      enableGitAnnex = true;
      dataDir = "/srv/git";
      user = "git";
      group = "git";
      extraGitoliteRc = ''
        $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
      '';
      adminPubkey = lib.trivial.pipe ../Keys/Ben.pub [
        builtins.readFile
        (lib.strings.splitString "\n")
        lib.lists.head
      ];
    };
  };
}