{ lib
, sources
, buildPythonPackage
}:

buildPythonPackage rec {
  pname = "interegular";
  version = sources.interegular.rev;
  format = "setuptools";

  src = sources.interegular;

  propagatedBuildInputs = [ ];

  doCheck = false;  # no tests currently
  pythonImportsCheck = [
    "interegular"
  ];

  meta = with lib; {
    description = "Allows to check regexes for overlaps.";
    homepage = "https://github.com/MegaIng/interegular";
    license = licenses.mit;
    maintainers = with maintainers; [ bsima ];
  };
}