_self: super:

{
  # Needs upgrading for guile 3
  # inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};

  guix = super.pkgs.stdenv.mkDerivation rec {
    pname = "guix";
    name = "${pname}-${version}";
    version = super.sources.guix.version;
    src = super.sources.guix;
    buildInputs = with super.pkgs; [
      guile
      # guile-gcrypt
      # guile-sql
      # guile-zlib
      # guile-lzlib
      # guile-avahi
      # guile-git
      # guile-json
      gnutls
      gnumake
      sqlite
      libgcrypt
      gcc
    ];
  };

  llm = super.overrideSrc super.llm super.sources.llm;

  nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix { };

  ollama = super.callPackage ./Deps/ollama.nix { acceleration = "cuda"; };

  # https://github.com/NixOS/nixpkgs/issues/317147#issuecomment-2147343125
  radicale = super.radicale.overrideAttrs (_old: rec {
    version = "3.2.0";
    src = super.fetchFromGitHub {
      owner = "Kozea";
      repo = "Radicale";
      rev = "v${version}";
      hash = "sha256-RxC8VOfdTXJZiAroDHTKjJqGWu65Z5uyb4WK1LOqubQ=";
    };
  });
}