From c790672cc244ac4caba1bda3572829a6c6862891 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Sun, 27 Oct 2019 09:48:52 -0700
Subject: move everything to namespace directories

---
 com/simatime/users.nix | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 com/simatime/users.nix

(limited to 'com/simatime/users.nix')

diff --git a/com/simatime/users.nix b/com/simatime/users.nix
new file mode 100644
index 0000000..daac9d6
--- /dev/null
+++ b/com/simatime/users.nix
@@ -0,0 +1,33 @@
+{ ... }:
+
+let
+  key = f: builtins.readFile (./keys/. + ("/" + f));
+in
+{
+  users = {
+    users = {
+      # bots
+      deploy = {
+        isNormalUser = true;
+        home = "/home/deploy";
+        openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
+        extraGroups = [ "wheel" ];
+      };
+
+      # humans
+      root.openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+      ben = {
+        isNormalUser = true;
+        home = "/home/ben";
+        openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+        extraGroups = [ "wheel" "networkmanager" "docker" ];
+      };
+      nick = {
+        isNormalUser = true;
+        home = "/home/nick";
+        openssh.authorizedKeys.keys = [ (key "nick.pub") ];
+        extraGroups = [ "docker" ];
+      };
+    };
+  };
+}
-- 
cgit v1.2.3