From 330e4363d8abb509031d2c8c1a89dcc6f955e2c1 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Fri, 4 Dec 2020 11:16:25 -0500
Subject: Renamespace Devalloc and Que

Move them under the Biz root so that we know they are specific to Biz stuff. Biz
is for proprietary stuff that we own.

I also had to refactor the bild namespace parsing code because it couldn't
handle a namespace with 3 parts. I really need to get that namespace library
written and tested.
---
 Que/Site.nix | 61 ------------------------------------------------------------
 1 file changed, 61 deletions(-)
 delete mode 100644 Que/Site.nix

(limited to 'Que/Site.nix')

diff --git a/Que/Site.nix b/Que/Site.nix
deleted file mode 100644
index ba2eeb2..0000000
--- a/Que/Site.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-
-
-let
-  cfg = config.services.que-website;
-  static = pkgs.stdenv.mkDerivation {
-    src = ./.;
-    name = "que-website-static";
-    installPhase = ''
-      mkdir -p $out
-      cp ${./Apidocs.md} $out/Apidocs.md
-      cp ${./Index.md} $out/Index.md
-      cp ${./Quescripts.md} $out/Quescripts.md
-      cp ${./Style.css} $out/Style.css
-      cp ${./Tutorial.md} $out/Tutorial.md
-      cp ${./Client.py} $out/Client.py
-    '';
-  };
-in
-{
-  options.services.que-website = {
-    enable = lib.mkEnableOption "Enable the que-website service";
-    namespace = lib.mkOption {
-      type = lib.types.str;
-      default = "_";
-      description = ''
-        The que namespace on which que-website will broadcast.
-      '';
-    };
-    package = lib.mkOption {
-      type = lib.types.package;
-      description = "que-website package to use";
-    };
-  };
-  config = lib.mkIf cfg.enable {
-    systemd.services.que-website = {
-      path = [ cfg.package pkgs.pandoc ];
-      wantedBy = [ "multi-user.target" ];
-      script = ''
-        ${cfg.package}/bin/que-website ${static} ${cfg.namespace}
-      '';
-      description = ''
-        Que website server
-      '';
-      serviceConfig = {
-        User = "root";
-        Environment = "HOME=/root";
-        KillSignal = "INT";
-        Type = "simple";
-        Restart = "on-abort";
-        RestartSec = "1";
-      };
-    };
-  };
-}
-- 
cgit v1.2.3