From 65c2b30a288385cf3df4027d50080ac595bbcf83 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Thu, 2 Apr 2020 23:45:04 -0700
Subject: Reorganize and comment some of the nix code

---
 Com/Simatime/web.nix | 41 -----------------------------------------
 1 file changed, 41 deletions(-)
 delete mode 100644 Com/Simatime/web.nix

(limited to 'Com/Simatime/web.nix')

diff --git a/Com/Simatime/web.nix b/Com/Simatime/web.nix
deleted file mode 100644
index 22d7199..0000000
--- a/Com/Simatime/web.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ ... }:
-
-let
-  bensIp = "73.222.221.62";
-in
-{
-  services = {
-    nginx = {
-      enable = true;
-      recommendedGzipSettings = true;
-      recommendedOptimisation = true;
-      recommendedProxySettings = true;
-      recommendedTlsSettings = true;
-      virtualHosts = {
-        "bsima.me".root = "/home/ben/public_html/";
-        "www.bsima.me".root = "/home/ben/public_html/";
-        "simatime.com".locations."/".root = "/srv/www/";
-        "firefoxsync.simatime.com".locations."/".proxyPass = "http://localhost:5001";
-        "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
-        "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
-        "deluge.simatime.com".locations."/".proxyPass = "http://${bensIp}:8112";
-
-        "notebook.simatime.com".locations = {
-          "/" = {
-            proxyPass = "http://${bensIp}:3099";
-            proxyWebsockets = true;
-            extraConfig = ''
-              proxy_buffering off;
-              proxy_read_timeout 86400;
-
-            '';
-          };
-          "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
-            proxyPass = "http://${bensIp}:3099";
-            proxyWebsockets = true;
-          };
-        };
-      };
-    };
-  };
-}
-- 
cgit v1.2.3