From f4b8c0df041b063c0b47d2ec6c818a9c202fd833 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Wed, 15 Apr 2020 09:54:10 -0700
Subject: Re-namespacing

Moving away from the DNS-driven namespacing toward more condensed names,
mostly because I don't like typing so much.
---
 Biz/users.nix | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
 create mode 100644 Biz/users.nix

(limited to 'Biz/users.nix')

diff --git a/Biz/users.nix b/Biz/users.nix
new file mode 100644
index 0000000..b52043e
--- /dev/null
+++ b/Biz/users.nix
@@ -0,0 +1,39 @@
+{ config, ... }:
+
+{
+  users.motd = ''
+
+  welcome to the simatime network!
+  your host is '${config.networking.hostName}'
+
+  '';
+  users.mutableUsers = false;
+  users.users = { #
+    # bots
+    #
+    deploy = {
+      isNormalUser = true;
+      home = "/home/deploy";
+      openssh.authorizedKeys.keyFiles = [ ./keys/deploy.pub ];
+      extraGroups = [ "wheel" ];
+    };
+    #
+    # humans
+    #
+    root.openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+    ben = {
+      description = "Ben Sima";
+      isNormalUser = true;
+      home = "/home/ben";
+      openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+      extraGroups = [ "wheel" "networkmanager" "docker" ];
+    };
+    nick = {
+      description = "Nick Sima";
+      isNormalUser = true;
+      home = "/home/nick";
+      openssh.authorizedKeys.keyFiles = [ ./keys/nick.pub ];
+      extraGroups = [ "docker" ];
+    };
+  };
+}
-- 
cgit v1.2.3