From f4b8c0df041b063c0b47d2ec6c818a9c202fd833 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Wed, 15 Apr 2020 09:54:10 -0700
Subject: Re-namespacing

Moving away from the DNS-driven namespacing toward more condensed names,
mostly because I don't like typing so much.
---
 Biz/Ibb/service.nix | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 Biz/Ibb/service.nix

(limited to 'Biz/Ibb/service.nix')

diff --git a/Biz/Ibb/service.nix b/Biz/Ibb/service.nix
new file mode 100644
index 0000000..f9d0f36
--- /dev/null
+++ b/Biz/Ibb/service.nix
@@ -0,0 +1,42 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+  cfg = config.services.ibb;
+in
+{
+  options.services.ibb = {
+    enable = lib.mkEnableOption "Enable the IBB service";
+    port = lib.mkOption {
+      type = lib.types.string;
+      default = "3000";
+      description = ''
+        The port on which IBB will listen for
+        incoming HTTP traffic.
+      '';
+    };
+  };
+  config = lib.mkIf cfg.enable {
+    systemd.services.ibb = {
+      path = with pkgs; [ ibb bash ];
+      wantedBy = [ "multi-user.target" ];
+      script = ''
+        PORT=${cfg.port} ./bin/ibb
+      '';
+      description = ''
+        Influenced By Books website
+      '';
+      serviceConfig = {
+        WorkingDirectory = pkgs.ibb;
+        KillSignal = "INT";
+        Type = "simple";
+        Restart = "on-abort";
+        RestartSec = "10";
+      };
+    };
+  };
+}
-- 
cgit v1.2.3