From db373a8c727cad91d375b40a6c70b11ed73bdafb Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Mon, 1 Apr 2024 13:30:45 -0400
Subject: Add nixfmt to Lint.hs

nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS
GitHub group. So I figure I should just adopt it without worrying too much about
the specifics of the formatting. I just formatted everything in one go, hence
the huge diff, oh well.
---
 Biz/Cloud/Comms/Xmpp.nix | 27 +++++++++++----------------
 1 file changed, 11 insertions(+), 16 deletions(-)

(limited to 'Biz/Cloud/Comms/Xmpp.nix')

diff --git a/Biz/Cloud/Comms/Xmpp.nix b/Biz/Cloud/Comms/Xmpp.nix
index af52f3f..ad8649b 100644
--- a/Biz/Cloud/Comms/Xmpp.nix
+++ b/Biz/Cloud/Comms/Xmpp.nix
@@ -11,22 +11,19 @@ let
 in {
   networking.firewall.allowedTCPPorts = [
     # https://prosody.im/doc/ports
-    5000  # file transfer
-    5222  # client connections
-    5269  # server-to-server
-    5280  # http
-    5281  # https
-    5347  # external components
-    5582  # telnet console
+    5000 # file transfer
+    5222 # client connections
+    5269 # server-to-server
+    5280 # http
+    5281 # https
+    5347 # external components
+    5582 # telnet console
   ];
 
   services.prosody = {
     enable = true;
-    package = pkgs.prosody.override {
-      withCommunityModules = [
-        "conversejs"
-      ];
-    };
+    package =
+      pkgs.prosody.override { withCommunityModules = [ "conversejs" ]; };
 
     # when i learn how to use security.acme better, and use separate certs, then i
     # can fix this group
@@ -36,7 +33,7 @@ in {
     inherit ssl;
     uploadHttp = {
       domain = "upload.${rootDomain}";
-      uploadExpireAfter = toString (60*60*24*30); # 30 days, as seconds
+      uploadExpireAfter = toString (60 * 60 * 24 * 30); # 30 days, as seconds
     };
 
     modules = {
@@ -129,9 +126,7 @@ in {
     };
   };
 
-  services.prosody-filer = {
-    enable = true;
-  };
+  services.prosody-filer = { enable = true; };
 
   services.nginx.virtualHosts."${rootDomain}".locations = {
     "/http-bind" = {
-- 
cgit v1.2.3