{ pkgs, lib, ... }:

{
  imports = [
    ../lib/common.nix
    ../lib/packages.nix
    ../lib/ssh.nix
  ];

  accounts = {
    email = {
      maildirBasePath = "mail";
      accounts = {
        "groq" = {
          primary = true;
          flavor = "gmail.com";
          realName = "Ben Sima";
          address = "bsima@groq.com";
          userName = "bsima@groq.com";
          mbsync = {
            enable = true;
            create = "both";
            expunge = "none";
          };
          notmuch.enable = true;
          msmtp.enable = true;
          passwordCommand = "secret-tool lookup email bsima@groq.io";
        };
      };
    };
  };

  services = {
    emacs.enable = true;
  };

  programs = {
    git = {
      userEmail = lib.mkOverride 10 "bsima@groq.com";
    };
  };
}