{ pkgs }:

# All common packages go here. Linux-specific should go in `linux.nix'

with pkgs;
let
  cmdtree = stdenv.mkDerivation {
    name = "cmdtree";
    src = fetchGit {
      url = "https://git.sr.ht/~jb55/cmdtree";
      ref = "master";
      rev = "5606078e8fa02462f0208d9f9cad98c7673812e6";
    };
    buildPhase = ''
      cp ${./cfg.def.h} ./cfg.def.h
      make
    '';
    installPhase = ''
      mkdir -p $out/bin
      cp ./cmdtree $out/bin
    '';
    buildInputs = [ pkgs.xorg.libX11 pkgs.xorg.libXft ];
  };
in
[
ag
aspellDicts.en
beets
bind
blueman
cloc
cmdtree
dict
dmenu
dolphin
entr
exercism
expect
fasd
feh
file
flameshot
glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
gopher
gnumake
hledger
hledger-ui
hledger-web
htop
ispell
jq
ledger
libnotify
lsof
minitube
mononoki
mplayer
msmtp
muchsync
ncdu
neomutt
nix-prefetch-scripts
obs-studio
pandoc
pass
pasystray
pdftk
qutebrowser
ranger
ripgrep
shellcheck
sqlite
tdesktop
terminus
texlive.combined.scheme-full
tmux
tree
unrar
unzip
urlscan
vlc
w3m
xorg.xmodmap
xournal
xterm
yank
youtube-dl
zoom-us

# languages i regularly use
clojure
ghc
guile
ocaml
python3
lispPackages.quicklisp
sbcl

]