From 5e16899ecf052a3d6fb91018cf0ac2e78419f687 Mon Sep 17 00:00:00 2001
From: Ben Sima <ben@bsima.me>
Date: Thu, 16 Apr 2020 21:31:55 -0700
Subject: Redo email stuff on linux

This will only work on my server... i'll have to refactor it if I want to use it
on my laptop too :(
---
 lib/email.nix | 60 +++++++++++++++--------------------------------------------
 1 file changed, 15 insertions(+), 45 deletions(-)

(limited to 'lib/email.nix')

diff --git a/lib/email.nix b/lib/email.nix
index e692d39..17ec44d 100644
--- a/lib/email.nix
+++ b/lib/email.nix
@@ -14,15 +14,12 @@ in
     email = {
       maildirBasePath = "${homedir}/Mail";
       accounts = {
-        "ben@bsima.me" = {
+        "ben@simatime.com" = {
           primary = true;
           realName = "Ben Sima";
           address = "ben@bsima.me";
           userName = "ben@simatime.com";
           alot.sendMailCommand = "${homedir}/bin/sendmail";
-          folders = {
-            inbox = "INBOX";
-          };
           imap = {
             host = "simatime.com";
             port = 993;
@@ -46,51 +43,24 @@ in
             expunge = "none";
           };
           notmuch.enable = true;
-          msmtp.enable = true;
-          passwordCommand = "cat ~/keybase/private/bsima/ben@bsima.me";
-        };
-
-        "ben@simatime.com" = {
-          realName = "Ben Sima";
-          address = "ben@simatime.com";
-          userName = "ben@simatime.com";
-          imap = {
-            host = "simatime.com";
-            port = 993;
-          };
-          smtp = {
-            host = "simatime.com";
-            port = 587;
-            tls = {
-              enable = true;
-              useStartTls = true;
-            };
-
-          };
-          mbsync = {
-            enable = true;
-            create = "both";
-            expunge = "none";
-          };
-          notmuch.enable = true;
           passwordCommand = "cat ~/keybase/private/bsima/ben@simatime.com";
           msmtp.enable = true;
         };
 
-        #"ben.sima@heroprojects.io" = {
-        #  flavor = "gmail.com";
-        #  realName = "Ben Sima";
-        #  address = "ben.sima@heroprojects.io";
-        #  userName = "ben.sima@heroprojects.io";
-        #  mbsync = {
-        #    enable = true;
-        #    create = "both";
-        #    expunge = "none";
-        #  };
-        #  notmuch.enable = true;
-        #  msmtp.enable = true;
-        #  passwordCommand = "pass work/hero/gmail";
-        #};
+        # "ben@heroprojects.io" = {
+        #   flavor = "gmail.com";
+        #   realName = "Ben Sima";
+        #   address = "ben@heroprojects.io";
+        #   userName = "ben@heroprojects.io";
+        #   mbsync = {
+        #     enable = true;
+        #     create = "both";
+        #     expunge = "none";
+        #   };
+        #   notmuch.enable = true;
+        #   msmtp.enable = true;
+        #   passwordCommand = "cat ~/keybase/private/bsima/ben@heroprojects.io";
+        # };
       };
     };
   };
-- 
cgit v1.2.3