From dc8c9efdb33130f960adc864916b67d0cb744dbb Mon Sep 17 00:00:00 2001
From: Tim Dettmers <tim.dettmers@gmail.com>
Date: Tue, 26 Jul 2022 10:32:22 -0700
Subject: Changed setup.py; deployed on test pypi.

---
 setup.py | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

(limited to 'setup.py')

diff --git a/setup.py b/setup.py
index 6cc091b..6275ddd 100644
--- a/setup.py
+++ b/setup.py
@@ -11,13 +11,14 @@ def read(fname):
 
 
 version = os.getenv("CUDA_VERSION", "cpu")
+prefix = '' if version == 'cpu' else 'cuda'
 
 setup(
-    name="bitsandbytes",
+    name=f"bitsandbytes-{prefix}{version}",
     version=f"0.30.0",
     author="Tim Dettmers",
     author_email="dettmers@cs.washington.edu",
-    description="8-bit optimizers and quantization routines.",
+    description="8-bit optimizers and matrix multiplication routines.",
     license="MIT",
     keywords="gpu optimizers optimization 8-bit quantization compression",
     url="http://packages.python.org/bitsandbytes",
-- 
cgit v1.2.3